summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-11-23 22:07:23 +0100
committerRicardo Wurmus <rekado@elephly.net>2016-11-27 09:48:41 +0100
commite9ef394ac918267fdaa889bf34e04cf539eb31cd (patch)
treecd8645fa0b463aa740c2a591a3251d8a6c405251 /gnu/packages
parent81157cf5a7bdbcdbbfba3e6fc280c49f7905a32d (diff)
downloadguix-e9ef394ac918267fdaa889bf34e04cf539eb31cd.tar.gz
gnu: Add perl-ipc-cmd.
* gnu/packages/perl.scm (perl-ipc-cmd): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/perl.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 226d1afa1e..a3f7c33a35 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -3323,6 +3323,26 @@ filehandles; in particular, IO::Scalar, IO::ScalarArray, and IO::Lines.")
 pseudo ttys.")
     (license (package-license perl))))
 
+(define-public perl-ipc-cmd
+  (package
+    (name "perl-ipc-cmd")
+    (version "0.96")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/B/BI/BINGOS/IPC-Cmd-"
+                           version ".tar.gz"))
+       (sha256
+        (base32
+         "0a2v44x70gj9fd5wa8i08f9z6n14qppj1j49m1hc333wh72mzk6i"))))
+    (build-system perl-build-system)
+    (home-page "http://search.cpan.org/dist/IPC-Cmd")
+    (synopsis "Run interactive command-line programs")
+    (description "@code{IPC::Cmd} allows for the searching and execution of
+any binary on your system.  It adheres to verbosity settings and is able to
+run interactively.  It also has an option to capture output/error buffers.")
+    (license (package-license perl))))
+
 (define-public perl-ipc-run
   (package
     (name "perl-ipc-run")