summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2014-09-28 09:35:32 +0200
committerAndreas Enge <andreas@enge.fr>2014-09-28 09:35:32 +0200
commit47e225cde8039f465365a997c3c5eaf6093b2e64 (patch)
tree2909cb98a8ec33d8586c5e3d331bf10783f81233 /gnu/packages
parentfcb0109d091622e756781ddac71bd663e5e9c98e (diff)
downloadguix-47e225cde8039f465365a997c3c5eaf6093b2e64.tar.gz
gnu: qt-4: Explicitly link with icu.
* gnu/packages/qt.scm (qt-4): Explicitly link with libicui18n, which is
    dlopened by QtCore.so.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/qt.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index ced7e90575..f57fedb379 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -172,6 +172,12 @@ developers using C++ or QML, a CSS & JavaScript like language.")
             (let ((out (assoc-ref outputs "out")))
               (substitute* '("configure")
                            (("/bin/pwd") (which "pwd")))
+              ;; Explicitly link with icui18n, which is dlopened by
+              ;; QtCore.so. The LDFLAGS are in fact added to other flags
+              ;; determined by the configure phase.
+              ;; According to the nix recipe, this may be necessary for
+              ;; further libraries (cups, gtk-x11-2.0, libgdk-x11-2.0).
+              (setenv "LDFLAGS" "-licui18n")
               ;; do not pass "--enable-fast-install", which makes the
               ;; configure process fail
               (zero? (system*