summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2018-11-14 14:23:21 -0800
committerDanny Milosavljevic <dannym@scratchpost.org>2018-11-17 00:16:29 +0100
commit0c7707d53e66839a2beae8c05eddc91ac5a6d5e1 (patch)
tree8c97449980f9aca206cb2adb213529f7dcbeb027 /gnu/packages
parentbca6396749492ea9f48b4bc31054d986e31b3e52 (diff)
downloadguix-0c7707d53e66839a2beae8c05eddc91ac5a6d5e1.tar.gz
gnu: u-boot: Update to 2018.11.
* gnu/packages/bootloaders.scm (u-boot): Update to 2018.11.
(u-boot)[native-inputs]: Add lz4.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bootloaders.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index bce12d324d..2fa50a89b4 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -34,6 +34,7 @@
   #:use-module (gnu packages bison)
   #:use-module (gnu packages cdrom)
   #:use-module (gnu packages check)
+  #:use-module (gnu packages compression)
   #:use-module (gnu packages cross-base)
   #:use-module (gnu packages disk)
   #:use-module (gnu packages firmware)
@@ -360,7 +361,7 @@ tree binary files.  These are board description files used by Linux and BSD.")
 (define u-boot
   (package
     (name "u-boot")
-    (version "2018.09")
+    (version "2018.11")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -368,12 +369,13 @@ tree binary files.  These are board description files used by Linux and BSD.")
                     "u-boot-" version ".tar.bz2"))
               (sha256
                (base32
-                "0s122kyz1svvs2yjzj4j9qravl3ra4vn0fjqgski7rlczqyg56w3"))))
+                "0znkwljfwwn4y7j20pzz4ilqw8znphrfxns0x1lwdzh3xbr96z3k"))))
     (native-inputs
      `(("bc" ,bc)
        ("bison" ,bison)
        ("dtc" ,dtc)
        ("flex" ,flex)
+       ("lz4" ,lz4)
        ("openssl" ,openssl)
        ("python-2" ,python-2)
        ("python2-coverage" ,python2-coverage)