summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-02-07 15:58:21 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-02-07 15:59:54 +0200
commitfe476868df60426a09dea071882b972b591d5081 (patch)
tree0e44602f7288c9054d5bcf1bbafe58493d83c52d /gnu/packages
parentf2d06d4697bf41d88d99269d1198b95f43af4617 (diff)
downloadguix-fe476868df60426a09dea071882b972b591d5081.tar.gz
gnu: python2-pysqlite: Update to 2.8.1.
* gnu/packages/python.scm (python2-pysqlite): Update to 2.8.1.
[source]: Change to `pypi uri` syntax.
[home-page]: Update to new homepage.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm14
1 files changed, 4 insertions, 10 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index e2298a041a..b135ab7df1 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1080,27 +1080,21 @@ also includes an interface for tabix.")
 (define-public python2-pysqlite
   (package
     (name "python2-pysqlite")
-    (version "2.6.3a")                            ; see below
+    (version "2.8.1")
     (source
      (origin
       (method url-fetch)
-      ;; During the switch from code.google.com to pypi.python.org, the 2.6.3
-      ;; tarball was modified, but the version number was kept:
-      ;; <https://lists.gnu.org/archive/html/guix-devel/2014-02/msg00077.html>.
-      ;; Here we want to refer to the pypi-hosted 2.6.3 tarball.
-      (uri (string-append
-            "https://pypi.python.org/packages/source/p/pysqlite/pysqlite-"
-            "2.6.3" ".tar.gz"))
+      (uri (pypi-uri "pysqlite" version))
       (sha256
        (base32
-        "13djzgnbi71znjjyaw4nybg6smilgszcid646j5qav7mdchkb77y"))))
+        "0rm0zqyb363y6wljhfmbxs16jjv7p8nk1d8zgq9sdwj6js7y3jkm"))))
     (build-system python-build-system)
     (inputs
      `(("sqlite" ,sqlite)))
     (arguments
      `(#:python ,python-2 ; incompatible with Python 3
        #:tests? #f)) ; no test target
-    (home-page "https://pypi.python.org/pypi/pysqlite")
+    (home-page "http://github.com/ghaering/pysqlite")
     (synopsis "SQLite bindings for Python")
     (description
      "Pysqlite provides SQLite bindings for Python that comply to the