summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-04-07 11:08:40 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-04-07 17:31:58 +0300
commit912b6ab01c405f693470ccb0c86a5e652674529a (patch)
tree01c5b80390c65629c797ae607dcf8a1cff58550c /gnu/packages
parentb94098af1e54b6c89efa4685e2bb92df4e2ef2c5 (diff)
downloadguix-912b6ab01c405f693470ccb0c86a5e652674529a.tar.gz
gnu: libgit2: Upgrade to 1.0.0.
* gnu/packages/version-control.scm (libgit2): Upgrade to 1.0.0.
[source]: Download using url-fetch.
[arguments]: Remove 'fix-pcre2-reference, 'make-git-checkout-writable
custom phases.
[home-page]: Update home-page.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/version-control.scm27
1 files changed, 7 insertions, 20 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index ac88515c25..fdbfab2fa4 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -601,16 +601,15 @@ on @command{git}, and use any regular Git hosting service.")
 (define-public libgit2
   (package
     (name "libgit2")
-    (version "0.99.0")
+    (version "1.0.0")
     (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/libgit2/libgit2.git")
-                    (commit (string-append "v" version))))
-              (file-name (git-file-name name version))
+              (method url-fetch)
+              (uri (string-append "https://github.com/libgit2/libgit2/"
+                                  "releases/download/v" version
+                                  "/libgit2-" version ".tar.gz"))
               (sha256
                (base32
-                "0qxzv49ip378g1n7hrbifb9c6pys2kj1hnxcafmbb94gj3pgd9kg"))
+                "1d09ni0v3vammk8zqmmwks92fh3wwnsxpyrh4s5wwdb3gxma27va"))
               (patches (search-patches "libgit2-mtime-0.patch"))
               (snippet '(begin
                           (delete-file-recursively "deps") #t))
@@ -623,14 +622,6 @@ on @command{git}, and use any regular Git hosting service.")
                            "-DUSE_HTTP_PARSER=system")
        #:phases
        (modify-phases %standard-phases
-         (add-after 'unpack 'fix-pcre2-reference
-           (lambda _
-             ;; Use PCRE2 with 8-bit character support, as there is no "libpcre2.pc".
-             ;; See <https://github.com/libgit2/libgit2/issues/5438>.
-             (substitute* "src/CMakeLists.txt"
-               (("\"libpcre2\"")
-                "\"libpcre2-8\""))
-             #t))
          (add-after 'unpack 'fix-hardcoded-paths
            (lambda _
              (substitute* "tests/repo/init.c"
@@ -639,10 +630,6 @@ on @command{git}, and use any regular Git hosting service.")
                (("/bin/cp") (which "cp"))
                (("/bin/rm") (which "rm")))
              #t))
-         (add-after 'unpack 'make-git-checkout-writable
-           (lambda _
-             (for-each make-file-writable (find-files "."))
-             #t))
          ;; Run checks more verbosely.
          (replace 'check
            (lambda _ (invoke "./libgit2_clar" "-v" "-Q"))))))
@@ -657,7 +644,7 @@ on @command{git}, and use any regular Git hosting service.")
      `(("openssl" ,openssl)
        ("pcre2" ,pcre2)
        ("zlib" ,zlib)))
-    (home-page "https://libgit2.github.com/")
+    (home-page "https://libgit2.org/")
     (synopsis "Library providing Git core methods")
     (description
      "Libgit2 is a portable, pure C implementation of the Git core methods