summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-16 06:34:22 -0400
committerMark H Weaver <mhw@netris.org>2018-03-16 06:44:24 -0400
commit1a83e2a286f258de8d887c28130b7baf038fd3e5 (patch)
tree518317fd4fb4d6e9e635866ff0bd40f4b0e2b598 /gnu/packages
parentc2af3b0725a25daa0b66a9943334ed997478b985 (diff)
downloadguix-1a83e2a286f258de8d887c28130b7baf038fd3e5.tar.gz
gnu: guile-static-stripped: Use invoke instead of system*.
* gnu/packages/make-bootstrap.scm (guile-static-stripped)[arguments]: Use
invoke and remove vestigial plumbing.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/make-bootstrap.scm31
1 files changed, 16 insertions, 15 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index eaef4c89c2..0b41d2cbc7 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -590,21 +590,22 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
            (mkdir (string-append out "/bin"))
            (copy-file guile1 guile2)
 
-           ;; Does the relocated Guile work?
-           (and ,(if (%current-target-system)
-                     #t
-                     '(zero? (system* guile2 "--version")))
-                (begin
-                  ;; Strip store references.
-                  (remove-store-references guile2)
-
-                  ;; Does the stripped Guile work?  If it aborts, it could be
-                  ;; that it tries to open iconv descriptors and fails because
-                  ;; libc's iconv data isn't available (see
-                  ;; `guile-default-utf8.patch'.)
-                  ,(if (%current-target-system)
-                       #t
-                       '(zero? (system* guile2 "--version")))))))))
+           ;; Verify that the relocated Guile works.
+           ,@(if (%current-target-system)
+                 '()
+                 '((invoke guile2 "--version")))
+
+           ;; Strip store references.
+           (remove-store-references guile2)
+
+           ;; Verify that the stripped Guile works.  If it aborts, it could be
+           ;; that it tries to open iconv descriptors and fails because libc's
+           ;; iconv data isn't available (see `guile-default-utf8.patch'.)
+           ,@(if (%current-target-system)
+                 '()
+                 '((invoke guile2 "--version")))
+
+           #t))))
     (inputs `(("guile" ,%guile-static)))
     (outputs '("out"))
     (synopsis "Minimal statically-linked and relocatable Guile")))