summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-10-23 09:45:09 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-10-23 10:30:59 +0300
commit26be7f23f8cc2fea01d06e251535fc40f23726e4 (patch)
treece31e3c5fb43fd2cb188c020a6c5ce1774b6cdd9 /gnu/packages
parentdf2252674025d9699f2a6ebd93f6e249ee8a3d92 (diff)
downloadguix-26be7f23f8cc2fea01d06e251535fc40f23726e4.tar.gz
gnu: Add rust-clap-2.
* gnu/packages/rust-cbindgen.scm (rust-clap-2): New hidden variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/rust-cbindgen.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/rust-cbindgen.scm b/gnu/packages/rust-cbindgen.scm
index 0a5e50e1ec..c7d3133489 100644
--- a/gnu/packages/rust-cbindgen.scm
+++ b/gnu/packages/rust-cbindgen.scm
@@ -128,3 +128,24 @@ depending on a large number of #[cfg] parameters.  Structured like an
     (properties '((hidden? . #t)))
     (license (list license:asl2.0
                    license:expat))))
+
+(define rust-clap-2
+  (package
+    (name "rust-clap")
+    (version "2.33.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "clap" version))
+        (file-name (string-append name "-" version ".crate"))
+        (sha256
+         (base32
+          "1nf6ld3bims1n5vfzhkvcb55pdzh04bbhzf8nil5vvw05nxzarsh"))))
+    (build-system cargo-build-system)
+    (home-page "https://clap.rs/")
+    (synopsis "Command Line Argument Parser")
+    (description
+     "This package provides a simple to use, efficient, and full-featured
+Command Line Argument Parser.")
+    (properties '((hidden? . #t)))
+    (license license:expat)))