summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-10-31 01:25:59 -0400
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:33 -0500
commit11b1b6cdd479f5228f16fa33b9d09530366940ab (patch)
tree8b9c55ba1895d8bad9e94c8a964272613b11f6fd /gnu/packages
parentb9debc37b80df414925e1b0438b3c0377f3d3b1b (diff)
downloadguix-11b1b6cdd479f5228f16fa33b9d09530366940ab.tar.gz
gnu: ghc-auto-update: Update to 0.1.6.
* gnu/packages/haskell-xyz.scm (ghc-auto-update): Update to 0.1.6.
[native-inputs] Add 'ghc-hspec', 'ghc-hunit', 'ghc-retry', and
'hspec-discover'.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/haskell-xyz.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index d5ce5400ee..7c0336095c 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -519,7 +519,7 @@ from aeson.")
 (define-public ghc-auto-update
   (package
     (name "ghc-auto-update")
-    (version "0.1.4")
+    (version "0.1.6")
     (source
      (origin
        (method url-fetch)
@@ -529,8 +529,13 @@ from aeson.")
              ".tar.gz"))
        (sha256
         (base32
-         "09dlh2alsx2mw5kvj931yhbj0aw7jmly2cm9xbscm2sf098w35jy"))))
+         "1i36xc2i34aync8271x3pv515l3zb53i518dybn8ghqkhzf27q7l"))))
     (build-system haskell-build-system)
+    (native-inputs
+     `(("ghc-hspec" ,ghc-hspec)
+       ("ghc-hunit" ,ghc-hunit)
+       ("ghc-retry" ,ghc-retry)
+       ("hspec-discover" ,hspec-discover)))
     (home-page "https://github.com/yesodweb/wai")
     (synopsis "Efficiently run periodic, on-demand actions")
     (description "This library provides mechanisms to efficiently run