summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-11-12 16:11:36 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2019-11-12 16:11:36 +0100
commit1524e757e1fafe5acf4ec44d8a9811ec5f06a86f (patch)
treefb004b62b29759348c1b9c7502c2f8508b7f3cc1 /gnu/packages
parent70b6286af63b5fbbf5c08d711c92469b04b4e7e5 (diff)
downloadguix-1524e757e1fafe5acf4ec44d8a9811ec5f06a86f.tar.gz
gnu: Add emacs-flycheck-cpplint.
* gnu/packages/emacs-xyz.scm (emacs-flycheck-cpplint): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 7481b6c226..5bbc33d451 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -19811,3 +19811,28 @@ such as:
 - swap windows à-la @code{windmove}.
 @end itemize\n")
     (license license:gpl3+)))
+
+(define-public emacs-flycheck-cpplint
+  (let ((commit "1d8a090861572258ab704915263feeb3a436c3d2")
+        (revision "1"))
+    (package
+      (name "emacs-flycheck-cpplint")
+      (version (git-version "0.1" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/flycheck/flycheck-google-cpplint")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0l6sg83f6z8x2alnblpv03rj442sbnkkkcbf8i0agjmx3713a5yx"))))
+      (build-system emacs-build-system)
+      (propagated-inputs
+       `(("flycheck-mode" ,emacs-flycheck)))
+      (synopsis "Google C++ checker for Flycheck")
+      (description "This package provides a interface for @code{cpplint} over
+Flycheck plugin.  @code{cpplint} is a static code checker for C++, following
+Google guidelines.")
+      (home-page "https://github.com/flycheck/flycheck-google-cpplint")
+      (license license:gpl3+))))