summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-10-11 00:50:01 -0400
committerLeo Famulari <leo@famulari.name>2017-10-12 21:22:45 -0400
commit4d93ebb31363bbe5a1a6ac06772863a9c36fb4c2 (patch)
treed5b574f0fd69e8b9f3435e920dbaa08d55a9b7a9 /gnu/packages
parenta3a5b01240174b0d5e12b41dd1187c106d88de6d (diff)
downloadguix-4d93ebb31363bbe5a1a6ac06772863a9c36fb4c2.tar.gz
gnu: Add go-github-com-gobwas-glob.
* gnu/packages/syncthing.scm (go-github-com-gobwas-glob): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/syncthing.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index a98502ce5a..cd78e22dee 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -164,3 +164,26 @@ structs in the Go programming language.")
       (description "This packages provides a Go implementation of mmap.")
       (home-page "https://github.com/edsrzf/mmap-go")
       (license bsd-3))))
+
+(define-public go-github-com-gobwas-glob
+  (let ((commit "51eb1ee00b6d931c66d229ceeb7c31b985563420")
+        (revision "0"))
+    (package
+      (name "go-github-com-gobwas-glob")
+      (version (git-version "0.0.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                       (url "https://github.com/gobwas/glob")
+                       (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "090wzpwsjana1qas8ipwh1pj959gvc4b7vwybzi01f3bmd79jwlp"))))
+      (build-system go-build-system)
+      (arguments
+        `(#:import-path "github.com/gobwas/glob"))
+      (synopsis "Go globbing library")
+      (description "This packages provides a Go implementation of globs.")
+      (home-page "https://github.com/gobwas/glob")
+      (license expat))))