summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-11-12 15:05:46 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-11-12 15:12:30 +0100
commit664cb939c61198e62398615525d5fe9835b2df38 (patch)
treec467fbd73f74ae782d783ec441daf4d7ad9f5b0f /gnu/packages
parent543f7ad14b12736e883868778aee33e1d8757b94 (diff)
downloadguix-664cb939c61198e62398615525d5fe9835b2df38.tar.gz
gnu: light: Don't use unstable tarball.
* gnu/packages/linux.scm (light)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/linux.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 36549fc0cb..71d3db62d3 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4961,15 +4961,15 @@ monitoring tools for Linux.  These include @code{mpstat}, @code{iostat},
   (package
     (name "light")
     (version "1.2.1")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append
-                     "https://github.com/haikarainen/light/archive/v"
-                     version ".tar.gz"))
-              (sha256
-               (base32
-                "14vj7v3mffpp0298vnzymp8ndasa0p3qv8i6iq3f4gc1717yglak"))
-              (file-name (string-append name "-" version ".tar.gz"))))
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/haikarainen/light.git")
+             (commit (string-append "v" version))))
+       (sha256
+        (base32 "0zrjipd392bzjvxx0rjrb0cgi0ix1d83fwgw1mcy8kc4d16cgyjg"))
+       (file-name (git-file-name name version))))
     (build-system gnu-build-system)
     (native-inputs
      `(("autoconf" ,autoconf)