summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-10-02 18:53:20 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-10-02 21:00:27 +0300
commit8ce47c20209ad9b87e1b7595556f22b2b5e2b8a2 (patch)
tree3bf8f72b7a155294510e51aac89a2cb5d3a537d9 /gnu/packages
parent6a3823de895b4bf36af65e08b128a9c103ca337f (diff)
downloadguix-8ce47c20209ad9b87e1b7595556f22b2b5e2b8a2.tar.gz
gnu: efl: Build with elogind support.
* gnu/packages/enlightenment.scm (efl)[arguments]: Add configure flag to
enable support for elogind.
[propagated-inputs]: Add elogind.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/enlightenment.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/enlightenment.scm b/gnu/packages/enlightenment.scm
index f3434c654d..8384f4c0ed 100644
--- a/gnu/packages/enlightenment.scm
+++ b/gnu/packages/enlightenment.scm
@@ -113,6 +113,7 @@
      `(("avahi" ,avahi)
        ("bullet" ,bullet)
        ("dbus" ,dbus)
+       ("elogind" ,elogind)
        ("eudev" ,eudev)
        ("fontconfig" ,fontconfig)
        ("freetype" ,freetype)
@@ -142,6 +143,8 @@
                            ;(string-append "-Ddictionaries-hyphen-dir="
                            ;               (assoc-ref %build-inputs "hyphen")
                            ;               "/share/hyphen")
+                           "-Delogind=true"
+                           "-Dnetwork-backend=connman"
                            ,@(match (%current-system)
                                ("armhf-linux"
                                 '("-opengl=es-egl"))