summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-11-22 00:05:25 -0300
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-11-24 14:01:03 +0100
commit9e7382f865deb2fc718ecdf19608954736590ded (patch)
treec82f1ba26fb2a5022c11ef76035715d466a22eca /gnu/packages
parent77a98bcd6ef79151f442f32d73f313e9b86cf9b7 (diff)
downloadguix-9e7382f865deb2fc718ecdf19608954736590ded.tar.gz
gnu: Add python-baycomp.
* gnu/packages/python-science.scm (python-baycomp): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-science.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 101c8fb640..99903ef247 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -439,6 +439,32 @@ doing practical, real world data analysis in Python.")
 written in C.")
     (license license:bsd-2)))
 
+(define-public python-baycomp
+  (package
+    (name "python-baycomp")
+    (version "1.0.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "baycomp" version))
+       (sha256
+        (base32 "1c1354a7b3g8slychjgyjxqdm8z40z9kviyl9n4g9kfpdg0p4d64"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-matplotlib" ,python-matplotlib)
+       ("python-numpy" ,python-numpy)
+       ("python-scipy" ,python-scipy)))
+    (home-page "https://github.com/janezd/baycomp")
+    (synopsis "Library for comparison of Bayesian classifiers")
+    (description
+     "Baycomp is a library for Bayesian comparison of classifiers.  Functions
+in the library compare two classifiers on one or on multiple data sets.  They
+compute three probabilities: the probability that the first classifier has
+higher scores than the second, the probability that differences are within the
+region of practical equivalence (rope), or that the second classifier has
+higher scores.")
+    (license license:expat)))
+
 (define-public python-xarray
   (package
     (name "python-xarray")