summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-10-30 14:39:37 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2019-10-30 14:40:49 +0100
commitcd6a22d1ac2bc2043f2d20b28fc8de5ec739bff4 (patch)
tree46701611bf0a41915042d3c6e717dbc697ad8720 /gnu/packages
parente16acb5c9b523a34a77c7fcddb986cd6840ba24c (diff)
downloadguix-cd6a22d1ac2bc2043f2d20b28fc8de5ec739bff4.tar.gz
gnu: Add emacs-eshell-did-you-mean.
* gnu/packages/emacs-xyz.scm (emacs-eshell-did-you-mean): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6b586abfcc..6f584f72b7 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -19647,3 +19647,25 @@ variable and the @code{minibuffer-line} face.")
 info, git branch, git dirty info and git unpushed number.  Multiple themes are
 available.")
       (license license:gpl3+))))
+
+(define-public emacs-eshell-did-you-mean
+  (package
+    (name "emacs-eshell-did-you-mean")
+    (version "0.1")
+    (home-page "https://github.com/xuchunyang/eshell-did-you-mean")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url home-page)
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0v0wshck5n4hspcv1zk1g2nm6xiigcjp16lx0dc8wzkl6ymljvbg"))))
+    (build-system emacs-build-system)
+    (synopsis "Display suggestions on 'command not found' in Eshell")
+    (description "This library adds a list of 'Did you mean...' suggestions
+when the command was not found in Eshell.  The suggestions are found after the
+commands that bear resemblance to the input command.")
+    (license license:gpl3+)))