summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-23 02:26:50 -0400
committerMark H Weaver <mhw@netris.org>2018-03-23 04:42:04 -0400
commitecb67a18b0acff90dfb275feefc407bbc947c23e (patch)
tree752dbcdf24f5b236e69acd314421f68496ed2bb3 /gnu/packages
parenteb075eddfcbe17b73f3bce9e932c234e50aad3a5 (diff)
downloadguix-ecb67a18b0acff90dfb275feefc407bbc947c23e.tar.gz
gnu: git: Return #t from all phases.
* gnu/packages/version-control.scm (git)[arguments]: Return #t from
the 'split' phase.  Use 'invoke' in the 'install-man-pages' phase.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/version-control.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 1ed6b303fc..36dbce4688 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -346,7 +346,9 @@ as well as the classic centralized workflow.")
               (wrap-program git-sm
                 `("PATH" ":" prefix
                   (,(string-append (assoc-ref inputs "perl")
-                                   "/bin")))))))
+                                   "/bin"))))
+
+              #t)))
         (add-after 'split 'install-man-pages
           (lambda* (#:key inputs outputs #:allow-other-keys)
             (let* ((out (assoc-ref outputs "out"))
@@ -354,7 +356,7 @@ as well as the classic centralized workflow.")
                    (manpages (assoc-ref inputs "git-manpages")))
               (mkdir-p man)
               (with-directory-excursion man
-                (zero? (system* "tar" "xvf" manpages)))))))))
+                (invoke "tar" "xvf" manpages))))))))
 
    (native-search-paths
     ;; For HTTPS access, Git needs a single-file certificate bundle, specified