summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
author(unmatched-parenthesis <paren@disroot.org>2022-10-21 22:11:22 +0100
committerRaghav Gururajan <rg@raghavgururajan.name>2022-11-27 10:31:38 -0500
commit9bb0001a0e4b262538af49f88386e4e52ea1fa00 (patch)
tree9b13bb6a230f6a88f499b26a5b6945e7fa47cb62 /gnu/packages
parent5e2c3f90357cbed689b37bfd3d356594a4c562c7 (diff)
downloadguix-9bb0001a0e4b262538af49f88386e4e52ea1fa00.tar.gz
gnu: Add go-github-com-arran4-golang-ical.
* gnu/packages/golang.scm (go-github-com-arran4-golang-ical): New
  variable.

Signed-off-by: Raghav Gururajan <rg@raghavgururajan.name>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 3dc9ecf67e..a177b54260 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -11085,6 +11085,35 @@ useful during debugging, to avoid wrapping long output lines in the
 terminal.")
     (license license:expat)))
 
+(define-public go-github-com-arran4-golang-ical
+  (package
+    (name "go-github-com-arran4-golang-ical")
+    (version "0.0.0-20220517104411-fd89fefb0182")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/arran4/golang-ical")
+                    (commit (go-version->git-ref version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0bxs0b5yg26liiifc0cc41l307r0wc93hp8iygv8dgpc60yzncaw"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:import-path "github.com/arran4/golang-ical"))
+    (propagated-inputs (list go-gopkg-in-yaml-v3
+                             go-gopkg-in-check-v1
+                             go-github-com-stretchr-testify
+                             go-github-com-niemeyer-pretty
+                             go-github-com-kr-text
+                             go-github-com-davecgh-go-spew))
+    (home-page "https://github.com/arran4/golang-ical")
+    (synopsis "Handle iCalenders in Go")
+    (description
+     "The @code{ical} package provides an ICS/iCalender parser and
+serialiser for Go.")
+    (license license:asl2.0)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar