summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorjgart via Guix-patches via <guix-patches@gnu.org>2021-12-07 16:04:06 -0500
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-09 09:17:35 +0100
commitbfaf6c18016a091f3f36c079c4a58e49a123d9f0 (patch)
tree17bb931f945de43161ba0369f2fed5f0d43d3c77 /gnu/packages
parent1490e02ea29f4a1b2f5b9453d6f36d5b960964a5 (diff)
downloadguix-bfaf6c18016a091f3f36c079c4a58e49a123d9f0.tar.gz
gnu: emacs-evil-magit: Remove deprecated package.
* gnu/packages/emacs-xyz.scm (emacs-evil-magit): Delete variable.

evil-magit has been consolidated into evil-collection. The package has been
removed from MELPA since February. See here:
<https://github.com/emacs-evil/evil-magit>.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm36
1 files changed, 0 insertions, 36 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f093e67dd4..8e89eda77f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -20781,42 +20781,6 @@ and the Zotero research assistant: Insertion of links to Zotero items into an
 Org-mode file, and citations of Zotero items in Pandoc Markdown files.")
     (license license:gpl3+)))
 
-(define-public emacs-evil-magit
-  (let ((commit "98c076fbeb6d2d7d71e02dc204ba3ad5d577abda")
-        (revision "5"))
-    (package
-      (name "emacs-evil-magit")
-      (version (git-version "0.4.2" revision commit))
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               (url "https://github.com/emacs-evil/evil-magit")
-               (commit commit)))
-         (file-name (git-file-name name version))
-         (sha256
-          (base32
-           "0b4iplxh3rmy8jadhf05pgksv1798d68d1jrhfry93jca8x9crxs"))))
-      (build-system emacs-build-system)
-      (propagated-inputs
-       `(("emacs-evil" ,emacs-evil)
-         ("magit" ,emacs-magit)))
-      (arguments
-       `(#:tests? #t
-         #:test-command '("emacs" "-Q" "-batch"
-                          "-L" "."
-                          "-l" "evil-magit-tests"
-                          "-f" "ert-run-tests-batch-and-exit")))
-      (home-page
-       "https://github.com/emacs-evil/evil-magit")
-      (synopsis "Evil-based key bindings for Magit")
-      (description
-       "This Emacs library configures Magit and Evil to play well with each other.
-For some background see @url{https://github.com/magit/evil-magit/issues/1}.
-See the README at @url{https://github.com/justbur/evil-magit} for a table
-describing the key binding changes.")
-      (license license:gpl3+))))
-
 (define-public emacs-evil-multiedit
   (package
     (name "emacs-evil-multiedit")