summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-03-09 01:06:54 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-03-09 01:25:21 +0100
commit296398e672b7a9933828da9f4441c74eee1726de (patch)
tree452c58ec0bc171f56b3f6ff7d0c355a4459c0354 /gnu/packages
parent7e2e7a34d15ae2efb62726dbadea4463faa55458 (diff)
downloadguix-296398e672b7a9933828da9f4441c74eee1726de.tar.gz
gnu: texlive-latex-pdfpages: Rename to texlive-pdfpages.
* gnu/packages/tex.scm (texlive-pdfpages): New variable.
(texlive-latex-pdfpages): Deprecate variable.
* gnu/packages/docbook.scm (dblatex): Use new name.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/docbook.scm2
-rw-r--r--gnu/packages/tex.scm58
2 files changed, 41 insertions, 19 deletions
diff --git a/gnu/packages/docbook.scm b/gnu/packages/docbook.scm
index 4d85421d52..41aeed6e27 100644
--- a/gnu/packages/docbook.scm
+++ b/gnu/packages/docbook.scm
@@ -476,7 +476,7 @@ the in DocBook SGML DTDs.")
                                         texlive-listings
                                         texlive-latex-multirow
                                         texlive-latex-overpic
-                                        texlive-latex-pdfpages
+                                        texlive-pdfpages
                                         texlive-refcount
                                         texlive-subfigure
                                         texlive-titlesec
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 7cb8d7cfc3..e419917a80 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6571,29 +6571,51 @@ that is untidy; this package (though it is no substitute for a properly
 designed class) helps alleviate this untidiness.")
     (license license:lppl)))
 
-(define-public texlive-latex-pdfpages
-  (package
-    (name "texlive-latex-pdfpages")
-    (version (number->string %texlive-revision))
-    (source (origin
-              (method svn-fetch)
-              (uri (texlive-ref "latex" "pdfpages"))
-              (file-name (string-append name "-" version "-checkout"))
-              (sha256
-               (base32
-                "140kl8r7g2ak2frjn5pmwiwibfynyfwp897r9vk8pypmn390lzr2"))))
-    (build-system texlive-build-system)
-    (arguments '(#:tex-directory "latex/pdfpages"))
-    (home-page "https://www.ctan.org/pkg/pdfpages")
-    (synopsis "Include PDF documents in LaTeX")
-    (description
-     "This package simplifies the inclusion of external multi-page PDF
+(define-public texlive-pdfpages
+  (let ((template (simple-texlive-package
+                   "texlive-pdfpages"
+                   (list "doc/latex/pdfpages/"
+                         "source/latex/pdfpages/"
+                         "tex/latex/pdfpages/")
+                   (base32
+                    "0a68vxkygk20fp51fkp7nvs8mc7h6irdvxal8qsnn9zrgr965d76"))))
+    (package
+      (inherit template)
+      (outputs '("out" "doc"))
+      (arguments
+       (substitute-keyword-arguments (package-arguments template)
+         ((#:tex-directory _ '())
+          "latex/pdfpages")
+         ((#:build-targets _ '())
+          #~(list "pdfpages.ins"))
+         ((#:phases phases)
+          #~(modify-phases #$phases
+              (add-after 'unpack 'chdir
+                (lambda _
+                  (chdir "source/latex/pdfpages")))
+              (replace 'copy-files
+                (lambda _
+                  (let ((origin #$(package-source this-package))
+                        (source (string-append #$output
+                                               "/share/texmf-dist/source"))
+                        (doc (string-append #$output:doc
+                                            "/share/texmf-dist/doc")))
+                    (copy-recursively (string-append origin "/source") source)
+                    (copy-recursively (string-append origin "/doc") doc))))))))
+      (propagated-inputs
+       (list texlive-tools texlive-oberdiek texlive-graphics texlive-eso-pic))
+      (home-page "https://ctan.org/macros/latex/contrib/pdfpages")
+      (synopsis "Include PDF documents in LaTeX")
+      (description
+       "This package simplifies the inclusion of external multi-page PDF
 documents in LaTeX documents.  Pages may be freely selected and it is possible
 to put several logical pages onto each sheet of paper.  Furthermore a lot of
 hypertext features like hyperlinks and article threads are provided.  The
 package supports pdfTeX (pdfLaTeX) and VTeX.  With VTeX it is even possible to
 use this package to insert PostScript files, in addition to PDF files.")
-    (license license:lppl1.3+)))
+      (license license:lppl1.3+))))
+
+(define-deprecated-package texlive-latex-pdfpages texlive-pdfpages)
 
 (define-public texlive-stmaryrd
   (let ((template (simple-texlive-package