summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-03-06 11:46:22 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-03-06 12:22:15 +0100
commitb47d8363f9976f088c453ecd714e1bc88115a64e (patch)
tree21c4460f316d6e8c4fd010fe44d784453a8fac4c /gnu/packages
parentdf8a042de8aab0ae56b36155575173320a42a36a (diff)
downloadguix-b47d8363f9976f088c453ecd714e1bc88115a64e.tar.gz
gnu: texlive-latex-hycolor: Rename to texlive-hycolor.
* gnu/packages/tex.scm (texlive-hycolor): New variable.
(texlive-latex-hycolor): Deprecated alias.
(texlive-hyperref): Use new name.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm54
1 files changed, 39 insertions, 15 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index be34ccf711..15d7e8e707 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3322,21 +3322,45 @@ keyval, and lscape.")
 
 (define-deprecated-package texlive-latex-graphics texlive-graphics)
 
-(define-public texlive-latex-hycolor
-  (package
-    (inherit (simple-texlive-package
-              "texlive-latex-hycolor"
-              (list "/doc/latex/hycolor/README.md"
-                    "/tex/latex/hycolor/")
-              (base32
-               "026lfb4l7b3q8g6zc68siqandhb1x98cbycn7njknqva6s99aiqn")
-              #:trivial? #t))
-    (home-page "https://www.ctan.org/pkg/latex-graphics")
-    (synopsis "Color for hyperref and bookmark")
-    (description
-     "This package provides the code for the @code{color} option that is
+(define-public texlive-hycolor
+  (let ((template  (simple-texlive-package
+                    "texlive-hycolor"
+                    (list "doc/latex/hycolor/"
+                          "source/latex/hycolor/"
+                          "tex/latex/hycolor/")
+                    (base32
+                     "0hmkx37wwmznxjqqnca87shy7qrgqrh2cn5r941ddgivnym31xbh"))))
+    (package
+      (inherit template)
+      (outputs '("out" "doc"))
+      (arguments
+       (substitute-keyword-arguments (package-arguments template)
+         ((#:tex-directory _ '())
+          "latex/hycolor")
+         ((#:build-targets _ '())
+          #~(list "hycolor.dtx"))
+         ((#:phases phases)
+          #~(modify-phases #$phases
+              (add-after 'unpack 'chdir
+                (lambda _
+                  (chdir "source/latex/hycolor")))
+              (replace 'copy-files
+                (lambda* (#:key inputs #:allow-other-keys)
+                  (let ((origin (assoc-ref inputs "source"))
+                        (source (string-append #$output
+                                               "/share/texmf-dist/source"))
+                        (doc (string-append #$output:doc
+                                            "/share/texmf-dist/doc")))
+                    (copy-recursively (string-append origin "/source") source)
+                    (copy-recursively (string-append origin "/doc") doc))))))))
+      (home-page "https://www.ctan.org/pkg/latex-graphics")
+      (synopsis "Color for hyperref and bookmark")
+      (description
+       "This package provides the code for the @code{color} option that is
 used by @code{hyperref} and @code{bookmark}.")
-    (license license:lppl1.3c+)))
+      (license license:lppl1.3c+))))
+
+(define-deprecated-package texlive-latex-hycolor texlive-hycolor)
 
 (define-public texlive-xcolor
   (let ((template (simple-texlive-package
@@ -3492,7 +3516,7 @@ XML, using UTF-8 or a suitable 8-bit encoding.")
              texlive-ltxcmds
              texlive-pdfescape
              texlive-auxhook
-             texlive-latex-hycolor
+             texlive-hycolor
              texlive-latex-kvoptions
              texlive-latex-letltxmacro
              texlive-pdftexcmds