summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-03-10 14:20:25 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-03-18 00:19:57 +0100
commite399d6cae35bdd4eda1ab0dbc2e6848050bbdcaa (patch)
tree0fff9683d0f481d2ac088e2f586638300b5458fc /gnu/packages
parentec89471d8300fb3c9027f77e1d0afd263c790e15 (diff)
downloadguix-e399d6cae35bdd4eda1ab0dbc2e6848050bbdcaa.tar.gz
gnu: Switch from scrnsaverproto to xorgproto.
* gnu/packages/enlightenment.scm (efl)[inputs]: Remove SCRNSAVERPROTO.
* gnu/packages/mate.scm (mate-control-center,
mate-screensaver)[native-inputs]: Remove SCRNSAVERPROTO.
* gnu/packages/xorg.scm (libxscrnsaver)[propagated-inputs]: Change from
SCRNSAVERPROTO to XORGPROTO.
(scrnsaverproto)[properties]: Mark as superseded by XORGPROTO.
(xorg-server)[propagated-inputs]: Remove SCRNSAVERPROTO.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/enlightenment.scm1
-rw-r--r--gnu/packages/mate.scm2
-rw-r--r--gnu/packages/xorg.scm7
3 files changed, 3 insertions, 7 deletions
diff --git a/gnu/packages/enlightenment.scm b/gnu/packages/enlightenment.scm
index f3374eaeb1..653996538d 100644
--- a/gnu/packages/enlightenment.scm
+++ b/gnu/packages/enlightenment.scm
@@ -107,7 +107,6 @@
        ("openjpeg" ,openjpeg-1)
        ("poppler" ,poppler)
        ("printproto" ,printproto)
-       ("scrnsaverproto" ,scrnsaverproto)
        ("wayland-protocols" ,wayland-protocols)
        ("xinput" ,xinput)
        ("xpr" ,xpr)
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index 7b16127971..abd297acbe 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -923,7 +923,6 @@ icons on the MATE desktop.  It works on local and remote file systems.")
        ("intltool" ,intltool)
        ("yelp-tools" ,yelp-tools)
        ("desktop-file-utils" ,desktop-file-utils)
-       ("scrnsaverproto" ,scrnsaverproto)
        ("xorgproto" ,xorgproto)
        ("xmodmap" ,xmodmap)
        ("gobject-introspection" ,gobject-introspection)))
@@ -1192,7 +1191,6 @@ Re-decorates windows on un-maximise.
        ("intltool" ,intltool)
        ("mate-common" ,mate-common)
        ("pkg-config" ,pkg-config)
-       ("scrnsaverproto" ,scrnsaverproto)
        ("which" ,which)
        ("xorgproto" ,xorgproto)))
     (inputs
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index d04c83146d..377b927267 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -1481,7 +1481,7 @@ treat it as part of their software base when porting.")
       `(("libxext" ,libxext)
         ("libx11" ,libx11)))
     (propagated-inputs
-      `(("scrnsaverproto" ,scrnsaverproto)))
+      `(("xorgproto" ,xorgproto)))
     (native-inputs
       `(("pkg-config" ,pkg-config)))
     (home-page "https://www.x.org/wiki/")
@@ -1774,8 +1774,8 @@ query the X server about its usage of various resources.")
     (description
      "Screen Saver Extension defines a protocol to control screensaver
 features and to query screensaver info on specific windows.")
-    (license license:x11)))
-
+    (license license:x11)
+    (properties `((superseded . ,xorgproto)))))
 
 (define-public sessreg
   (package
@@ -5095,7 +5095,6 @@ over Xlib, including:
       `(("libpciaccess" ,libpciaccess)
         ("mesa" ,mesa)
         ("pixman" ,pixman)
-        ("scrnsaverproto" ,scrnsaverproto)
         ("xineramaproto" ,xineramaproto)
         ("xf86driproto" ,xf86driproto)
         ("xorgproto" ,xorgproto)))