summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-04-04 16:19:18 +0800
committer宋文武 <iyzsong@gmail.com>2015-04-05 10:37:59 +0800
commit68e3c29d202cb7201a69269159cac49527e62938 (patch)
tree6e56cbeff93c25f18ae0423a22d95e21655c49a3 /gnu/packages
parent0a588bf95668bbc66e6924f16db7f477c83ce217 (diff)
downloadguix-68e3c29d202cb7201a69269159cac49527e62938.tar.gz
gnu: Add libavc1394.
* gnu/packages/linux.scm (libavc1394): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/linux.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 3e796552ef..089ef588b2 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2024,3 +2024,26 @@ the Linux IEEE-1394 subsystem, which provides direct access to the connected
 send to and receive from other nodes without requiring a kernel driver for the
 protocol in question.")
     (license lgpl2.1+)))
+
+(define-public libavc1394
+  (package
+    (name "libavc1394")
+    (version "0.5.4")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://sourceforge/libavc1394/"
+                                  name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0lsv46jdqvdx5hx92v0z2cz3yh6212pz9gk0k3513sbaa04zzcbw"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (propagated-inputs
+     `(("libraw1394" ,libraw1394))) ; required by libavc1394.pc
+    (home-page "http://sourceforge.net/projects/libavc1394/")
+    (synopsis "AV/C protocol library for IEEE 1394")
+    (description
+     "Libavc1394 is a programming interface to the AV/C specification from
+the 1394 Trade Assocation.  AV/C stands for Audio/Video Control.")
+    (license lgpl2.1+)))