summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-10-27 22:13:22 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-10-27 22:13:22 +0300
commit13c4d8746be63e8cd4b49c52bb9bbfc873b324dd (patch)
tree764c7ec84ef2c16d9267e42ec9f456e7f4e1cdf1 /gnu/packages
parentb6e0804953fa310311ad3daf82738f0f03fe20dc (diff)
downloadguix-13c4d8746be63e8cd4b49c52bb9bbfc873b324dd.tar.gz
gnu: python-wtforms: Skip optional tests.
* gnu/packages/python.scm (python-wtforms)[arguments]: Add a phase
preventing tests from failing when optional tests aren't run.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 4215c3dc7f..691c5deab0 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -8093,6 +8093,17 @@ python-xdo for newer bindings.)")
         (base32
          "0vyl26y9cg409cfyj8rhqxazsdnd0jipgjw06civhrd53yyi1pzz"))))
     (build-system python-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'remove-django-test
+           ;; Don't fail the tests when the inputs for the optional tests cannot be found.
+           (lambda _
+             (substitute*
+               "tests/runtests.py"
+               (("'ext_django.tests', 'ext_sqlalchemy', 'ext_dateutil', 'locale_babel'") "")
+               (("sys.stderr.write(\"### Disabled test '%s', dependency not found\n\" % name)") ""))
+             #t)))))
     (native-inputs
      `(("unzip" ,unzip)))
     (home-page "http://wtforms.simplecodes.com/")