summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-01-06 23:14:59 +0100
committerLudovic Courtès <ludo@gnu.org>2015-01-07 16:48:50 +0100
commitbe11b1024474489ead4d6befa40d38fd39fb9b72 (patch)
treeb15712fdf8310dddabdd22deaa9f9d5fab9af5bf /gnu/packages
parent3cbb3f9c55290ba151df3d3bbb78c83cef7cf6c0 (diff)
downloadguix-be11b1024474489ead4d6befa40d38fd39fb9b72.tar.gz
gnu: guile: Depend on 'libltdl' rather than 'libtool'.
* gnu/packages/guile.scm (guile-1.8, guile-2.0): Replace LIBTOOL with
  LIBLTDL.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/guile.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 0796834369..0900768832 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -87,7 +87,7 @@
    ;; Since `guile-1.8.pc' has "Libs: ... -lgmp -lltdl", these must be
    ;; propagated.
    (propagated-inputs `(("gmp" ,gmp)
-                        ("libtool" ,libtool)))
+                        ("libltdl" ,libltdl)))
 
    ;; When cross-compiling, a native version of Guile itself is needed.
    (self-native-input? #t)
@@ -131,7 +131,10 @@ without requiring the source code to be rewritten.")
        ;; `-L' flags.  As for why the `.la' file lacks the `-L' flags, see
        ;; <http://thread.gmane.org/gmane.comp.lib.gnulib.bugs/18903>.
       ("libunistring" ,libunistring)
-      ("libtool" ,libtool)
+
+      ;; Depend on LIBLTDL, not LIBTOOL.  That way, we avoid some the extra
+      ;; dependencies that LIBTOOL has, which is helpful during bootstrap.
+      ("libltdl" ,libltdl)
 
       ;; The headers and/or `guile-2.0.pc' refer to these packages, so they
       ;; must be propagated.