summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-06-25 17:52:10 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-06-25 18:28:54 +0200
commiteed67cbb8ff6577a12f64cc7984996a23a02cd2a (patch)
tree2cf6b04eaf8a7dee5ce80a5d4b6afd3e369ccecc /gnu/packages
parent96693d1d92ba0d57cd47259e846bbb33c9076f32 (diff)
downloadguix-eed67cbb8ff6577a12f64cc7984996a23a02cd2a.tar.gz
gnu: Add default GCC and default gfortran.
* gnu/packages/gcc.scm (gcc): New variable.
* gnu/packages/gcc.scm (gfortran): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gcc.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 389610d9c1..4fc2e6355e 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -345,6 +345,8 @@ Go.  It also includes runtime support libraries for these languages.")
                             '("gcc-arm-link-spec-fix.patch"
                               "gcc-5.0-libvtv-runpath.patch")))))))
 
+(define-public gcc gcc-4.9)
+
 (define-public (make-libstdc++ gcc)
   "Return a libstdc++ package based on GCC.  The primary use case is when
 using compilers other than GCC."
@@ -397,6 +399,9 @@ using compilers other than GCC."
 (define-public gfortran-4.9
   (custom-gcc gcc-4.9 "gfortran" '("fortran")))
 
+(define-public gfortran
+  (custom-gcc gcc "gfortran" '("fortran")))
+
 (define-public gccgo-4.8
   (custom-gcc gcc-4.8 "gccgo" '("go")
               ;; Suppress the separate "lib" output, because otherwise the