summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-05-05 23:13:11 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-05-06 00:14:27 +0200
commit72032c9d5f5ab1a1b6892d1b1685255f68844057 (patch)
treee2fa633e97421d4e764a268f612cd5f3d1b008b4 /gnu/packages
parent6490cd31cc5b7ef6607ec28a05e9cd50793c0c50 (diff)
downloadguix-72032c9d5f5ab1a1b6892d1b1685255f68844057.tar.gz
gnu: Add r-base64url.
* gnu/packages/cran.scm (r-base64url): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 1cf0a59ec1..29d6e336e3 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4427,6 +4427,33 @@ files.")
 environment within Shiny.")
     (license license:expat)))
 
+(define-public r-base64url
+  (package
+    (name "r-base64url")
+    (version "1.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "base64url" version))
+       (sha256
+        (base32
+         "0n1c2b68vza1dh7sk38v6biiwm72c4jpl79kpdg1bsb0hq9qy18x"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-backports" ,r-backports)))
+    (home-page "https://github.com/mllg/base64url")
+    (synopsis "Fast and URL-safe base64 encoder and decoder")
+    (description
+     "This package provides a URL-safe base64 encoder and decoder.  In
+contrast to RFC3548, the 62nd character (@code{+}) is replaced with @code{-},
+the 63rd character (@code{/}) is replaced with @code{_}.  Furthermore, the
+encoder does not fill the string with trailing @code{=}.  The resulting
+encoded strings comply to the regular expression pattern @code{[A-Za-z0-9_-]}
+and thus are safe to use in URLs or for file names.  The package also comes
+with a simple base32 encoder/decoder suited for case insensitive file
+systems.")
+    (license license:gpl3)))
+
 (define-public r-radiant-data
   (package
     (name "r-radiant-data")