summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-06-02 21:31:11 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-06-03 02:21:23 +0200
commit898e8b528b6bde0a699cac81532181050344a548 (patch)
treecbd27480225448f12c7efbe615b1fa1164b5fcdc /gnu/packages
parent6978cb2865ee26c2eb46bfe5a907d35b701a56c6 (diff)
downloadguix-898e8b528b6bde0a699cac81532181050344a548.tar.gz
gnu: net-tools: Fix cross-compilation.
* gnu/packages/linux.scm (net-tools)[arguments]: Use CC-FOR-TARGET.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/linux.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 1e1ba787e2..12c37d8c51 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2150,7 +2150,7 @@ inadequately in modern network environments, and both should be deprecated.")
       (home-page "http://net-tools.sourceforge.net/")
       (build-system gnu-build-system)
       (arguments
-       '(#:modules ((guix build gnu-build-system)
+       `(#:modules ((guix build gnu-build-system)
                     (guix build utils)
                     (srfi srfi-1)
                     (srfi srfi-26))
@@ -2190,7 +2190,7 @@ inadequately in modern network environments, and both should be deprecated.")
 
          #:tests? #f                                ; no test suite
          #:make-flags (let ((out (assoc-ref %outputs "out")))
-                        (list "CC=gcc"
+                        (list ,(string-append "CC=" (cc-for-target))
                               (string-append "BASEDIR=" out)
                               (string-append "INSTALLNLSDIR=" out "/share/locale")
                               (string-append "mandir=/share/man")))))