summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-06-13 10:24:57 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-06-19 11:37:27 +0300
commite46e9573855d5ee4f71db0ce77159bbc636330c1 (patch)
treefb14739fcb96566a5b45fd94b0ca2bc413e92492 /gnu/packages
parent05e26d1ecd41bdac5ef531b9f6f5c0c6bfbf3a30 (diff)
downloadguix-e46e9573855d5ee4f71db0ce77159bbc636330c1.tar.gz
gnu: python: Skip one more test.
* gnu/packages/python.scm (python)[source]: Remove another test.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 1373e4bb75..505e4a813b 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -340,8 +340,11 @@ data types.")
                (base32
                 "1c6v1n9nz4mlx9mw1125fxpmbrgniqdbbx9hnqx44maqazb2mzpf"))
               (snippet
-               '(delete-file
-                  "Lib/ctypes/test/test_win32.py")))) ; fails on aarch64
+               '(begin
+                  (for-each delete-file
+                            '("Lib/ctypes/test/test_win32.py" ; fails on aarch64
+                              "Lib/test/test_fcntl.py"))
+                  #t))))
     (arguments (substitute-keyword-arguments (package-arguments python-2)
                  ((#:tests? _) #t)))
     (native-search-paths