summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-10-23 21:20:46 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 22:32:01 +0100
commitde5bc89093895744e9d0cdcf26c9b3bc971a8f0e (patch)
tree6b6607899e9375c47702c7575225b5e56b8ce79f /gnu/packages
parent54c85e12fda033ef01bb2c649b540d9694a368f3 (diff)
downloadguix-de5bc89093895744e9d0cdcf26c9b3bc971a8f0e.tar.gz
gnu: python2-pbcore: Fix inputs:
* gnu/packages/bioinformatics.scm (python2-pbcore) [inputs] change to
  [propagated-inputs]. [native-inputs]: Remove python-docutils, which
  comes with sphinx. [former propagated-inputs]: move all (which is only
  pyxb) to [inputs].
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioinformatics.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 0d5d8ff32a..f9929dfa4f 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3476,17 +3476,15 @@ interrupted by stop codons.  OrfM finds and prints these ORFs.")
                 "1kjmv891d6qbpp4shhhvkl02ff4q5xlpnls2513sm2cjcrs52f1i"))))
     (build-system python-build-system)
     (arguments `(#:python ,python-2)) ; pbcore requires Python 2.7
-    (inputs
+    (propagated-inputs
      `(("python-cython" ,python2-cython)
        ("python-numpy" ,python2-numpy)
        ("python-pysam" ,python2-pysam)
        ("python-h5py" ,python2-h5py)))
     (native-inputs
-     `(("python-docutils" ,python2-docutils)
-       ("python-nose" ,python2-nose)
-       ("python-sphinx" ,python2-sphinx)))
-    (propagated-inputs
-     `(("python-pyxb" ,python2-pyxb)))
+     `(("python-nose" ,python2-nose)
+       ("python-sphinx" ,python2-sphinx)
+       ("python-pyxb" ,python2-pyxb)))
     (home-page "http://pacificbiosciences.github.io/pbcore/")
     (synopsis "Library for reading and writing PacBio data files")
     (description