summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-07-31 10:38:02 -0300
committerMathieu Othacehe <othacehe@gnu.org>2020-08-01 09:32:44 +0200
commit1619d350a354bb6c04a34baa5bf4a2ac29a5ebe5 (patch)
tree3594dbf07db1afc3a6fafe7c250efdd47032bf98 /gnu/packages
parent3cc8b4fa26e56a64eebccecc327e5960adf22972 (diff)
downloadguix-1619d350a354bb6c04a34baa5bf4a2ac29a5ebe5.tar.gz
gnu: Add python-wurlitzer.
* gnu/packages/python-xyz.scm (python-wurlitzer): New variable.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a7c9049e09..9ab0b12383 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5031,6 +5031,34 @@ operators such as union, intersection, and difference.")
 (define-public python2-pysnptools
   (package-with-python2 python-pysnptools))
 
+(define-public python-wurlitzer
+  (package
+    (name "python-wurlitzer")
+    (version "2.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "wurlitzer" version))
+       (sha256
+        (base32 "0hvmbc41kdwrjns8z1s4a59a4azdvzb8q3vs7nn1li4qm4l0g3yh"))))
+    (build-system python-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda _
+             (invoke "pytest" "-vv" "test.py"))))))
+    (native-inputs
+     `(("python-mock" ,python-mock)
+       ("python-pytest" ,python-pytest)))
+    (home-page "https://github.com/minrk/wurlitzer")
+    (synopsis "Capture C-level output in context managers")
+    (description
+     "This library helps to redirect @code{sys.stdout} to a stream or a file
+while executing some piece of code, including C code running within a Python
+process.")
+    (license license:expat)))
+
 (define-public python-socksipy-branch
   (package
     (name "python-socksipy-branch")