summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJakub Kądziołka <kuba@kadziolka.net>2020-07-28 18:20:37 +0200
committerJakub Kądziołka <kuba@kadziolka.net>2020-07-30 02:53:28 +0200
commit8206a282b157fcf2d7435850587bf3ae29319698 (patch)
treefa680abeb7466a06fdf314d6583e10d2c9973516 /gnu/packages
parent54369b607fc0e5a773c560b4759b70b23b6bcd27 (diff)
downloadguix-8206a282b157fcf2d7435850587bf3ae29319698.tar.gz
gnu: bison: Mention yacc in the description.
This should help the user find the package if the goal is to satisfy a
dependency on yacc.

* gnu/packages/bison.scm (bison)[synopsis, description]: Explain
  compatibility with Yacc.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bison.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/bison.scm b/gnu/packages/bison.scm
index 725f38263f..4c6da7d9b7 100644
--- a/gnu/packages/bison.scm
+++ b/gnu/packages/bison.scm
@@ -3,6 +3,7 @@
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
+;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -57,12 +58,14 @@
     (inputs `(("flex" ,flex)))
     (propagated-inputs `(("m4" ,m4)))
     (home-page "https://www.gnu.org/software/bison/")
-    (synopsis "Parser generator")
+    (synopsis "Yacc-compatible parser generator")
     (description
      "GNU Bison is a general-purpose parser generator.  It can build a
 deterministic or generalized LR parser from an annotated, context-free
 grammar.  It is versatile enough to have many applications, from parsers for
-simple tools through complex programming languages.")
+simple tools through complex programming languages.
+
+Bison also provides an implementation of @command{yacc}, as specified by POSIX.")
     (license gpl3+)))
 
 (define-public bison-3.6