summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorPierre Neidhardt <ambrevar@gmail.com>2018-05-22 10:37:54 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-05-22 12:15:33 +0200
commitbdadf8557e9bd8bda70dcf40326f43ace7d28429 (patch)
treede7b0fc074f5fb33e0e7d71a13bd6e9cdf36b8a6 /gnu/packages
parent096c10cb47ce9d2e13c46d2b3cbf0d87d7c5d514 (diff)
downloadguix-bdadf8557e9bd8bda70dcf40326f43ace7d28429.tar.gz
gnu: Add emacs-daemons.
* gnu/packages/emacs.scm (emacs-daemons): New variable.

Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index ca78cb2bc2..053fe6d479 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -34,6 +34,7 @@
 ;;; Copyright © 2017, 2018 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2018 Sohom Bhattacharjee <soham.bhattacharjee15@gmail.com>
 ;;; Copyright © 2018 Mathieu Lirzin <mthl@gnu.org>
+;;; Copyright © 2018 Pierre Neidhardt <ambrevar@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -10469,3 +10470,27 @@ Dumb Jump performs best with The Silver Searcher @command{ag} or ripgrep
        "This package provides an Emacs minor mode for highlighting
 device tree files.")
       (license license:gpl3+))))
+
+(define-public emacs-daemons
+  (package
+    (name "emacs-daemons")
+    (version "1.2.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/cbowdon/daemons.el")
+             (commit version)))
+       (file-name (string-append name "-" version "-checkout"))
+       (sha256
+        (base32
+         "00ijgm22ck76gw0x79krl05yy0m8a502yfakazfy5xhpn1zi6ab7"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/cbowdon/daemons.el")
+    (synopsis "Emacs UI for managing init system services")
+    (description
+     "This is an Emacs mode to give you a UI for managing init system
+daemons (services) for those getting tired of typing out @code{sudo service
+my_thing reload} all the time.  Its offers a consistent UI over different init
+systems.")
+    (license license:gpl3+)))