summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorKei Yamashita <kei@openmailbox.org>2016-05-07 14:20:35 -0400
committerAlex Kost <alezost@gmail.com>2016-05-09 11:41:00 +0300
commit9c6b7ef54fa5e4dac0e21e16dee4dc54858250a2 (patch)
tree40b5292b826ede0e554750ff0e0f24e53eb158ae /gnu/packages
parent19e1d5f7f90194f1ac7e783b28a688ce1441786d (diff)
downloadguix-9c6b7ef54fa5e4dac0e21e16dee4dc54858250a2.tar.gz
gnu: Add wmfire.
* gnu/packages/gnustep.scm (wmfire): New variable.

Signed-off-by: Alex Kost <alezost@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gnustep.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/gnustep.scm b/gnu/packages/gnustep.scm
index f4a2b266a3..31fca5b504 100644
--- a/gnu/packages/gnustep.scm
+++ b/gnu/packages/gnustep.scm
@@ -24,6 +24,7 @@
   #:use-module (guix licenses)
   #:use-module (gnu packages xorg)
   #:use-module (gnu packages gnome)
+  #:use-module (gnu packages gtk)
   #:use-module (gnu packages texinfo)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages glib)
@@ -216,3 +217,31 @@ on.")
 a dockable tile.  It features multiple language support, 24h or 12h time
 display, and can run a user-specified program on mouse click.")
     (license gpl2+)))
+
+(define-public wmfire
+  (package
+    (name "wmfire")
+    (version "1.2.4")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://www.improbability.net/"
+                                  name "/" name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "101grahd80n97y2dczb629clmcgiavdpbbwy78kk5wgs362m12z3"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("gtk+" ,gtk+-2)
+       ("libgtop" ,libgtop)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "http://www.improbability.net/")
+    (synopsis "Display flames to represent CPU usage, memory usage, etc.")
+    (description
+     "wmfire is an applet for Window Maker that can monitor the average cpu
+load, or individual cpu load on SMP computers.  Additionally it can monitor the
+memory, network load, a file or just be set to show a pretty flame.  On
+entering the dock a burning spot replaces the cursor, and after two seconds
+symbols to represent the current monitor are \"burnt\" onscreen.  The flame
+colour can also be changed.")
+    (license gpl2+)))