summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-26 15:14:54 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-09-05 10:26:14 -0400
commit0ce7436fc8bc0264e9d36a19c04ad7c96151f819 (patch)
tree35d3de42b91ed99363594fbff95c25ca6dbee8b6 /gnu/packages
parenta5e8928b5f173c2421a76894d32676992616e27b (diff)
downloadguix-0ce7436fc8bc0264e9d36a19c04ad7c96151f819.tar.gz
gnu: cairomm-1.13: Fix build.
* gnu/packages/gtk.scm (cairomm-1.13)[build-system]: New field.
[arguments]: New field.
[propagated-inputs]: Replace libsigc++ with libsigc++-2.

Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gtk.scm17
1 files changed, 15 insertions, 2 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 0e39874ccb..d595f9dfd7 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1323,9 +1323,22 @@ library.")
                        name "-" version ".tar.gz"))
        (sha256
         (base32 "1xlfl0fm5mgv53lr8xjv2kqsk3bz67qkk6qzvbrqmbvbvvbqp9wp"))))
+    (build-system glib-or-gtk-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'install 'move-doc
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (doc (assoc-ref outputs "doc")))
+               (mkdir-p (string-append doc "/share"))
+               (rename-file
+                (string-append out "/share/doc")
+                (string-append doc "/share/doc"))
+               #t))))))
     (propagated-inputs
-     `(("cairo" ,cairo)
-       ("sigc++" ,libsigc++)))))
+     `(("libsigc++" ,libsigc++-2)
+       ,@(package-propagated-inputs cairomm)))))
 
 (define-public pangomm
   (package