summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLéo Le Bouter <lle-bout@zaclys.net>2021-03-10 11:17:53 +0100
committerLéo Le Bouter <lle-bout@zaclys.net>2021-03-10 11:20:08 +0100
commit47ce29666b0b66de906dcfebf24776f3e06f1572 (patch)
tree1fe918e9200989d33eca538eca725cee4bb82c3f /gnu/packages
parentf7fdafeff52cb900d76a1de855a5a238aacedd7d (diff)
downloadguix-47ce29666b0b66de906dcfebf24776f3e06f1572.tar.gz
gnu: botan: Update to 2.17.3 [fixes CVE-2021-24115].
* gnu/packages/crypto.scm (botan): Update to 2.17.3.
[arguments]: Add 'library-path-for-tests phase to fix 'check phase by setting
LD_LIBRARY_PATH to intermediate build directory so tests can find libbotan.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crypto.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 5c8e4d6b22..0000e7fbf2 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -887,14 +887,14 @@ SHA256, SHA512, SHA3, AICH, ED2K, Tiger, DC++ TTH, BitTorrent BTIH, GOST R
 (define-public botan
   (package
     (name "botan")
-    (version "2.12.1")
+    (version "2.17.3")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://botan.randombit.net/releases/"
                                   "Botan-" version ".tar.xz"))
               (sha256
                (base32
-                "1ada3ga7b0z4m0vjmxlvfi4nsic2l8kjcy85jwss3z2i58a5y0vy"))))
+                "121vn1aryk36cpks70kk4c4cfic5g0qs82bf92xap9258ijkn4kr"))))
     (build-system gnu-build-system)
     (arguments
      '(#:phases
@@ -916,6 +916,8 @@ SHA256, SHA512, SHA3, AICH, ED2K, Tiger, DC++ TTH, BitTorrent BTIH, GOST R
 
                        ;; Recommended by upstream
                        "--with-zlib" "--with-bzip2" "--with-sqlite3"))))
+         (add-before 'check 'library-path-for-tests
+           (lambda _ (setenv "LD_LIBRARY_PATH" (getcwd))))
          (replace 'check
            (lambda _ (invoke "./botan-test"))))))
     (native-inputs