summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-04-23 22:30:40 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-09-05 10:26:27 -0400
commit72e24718204a5206f2d09356c2a2e7b6cbfa0f2e (patch)
tree540e87924c0c4a9cabc41dad1809d0c1c1750ab6 /gnu/packages
parentcf071a7c6c73e3c3eb4f04b04b0919668f6330f2 (diff)
downloadguix-72e24718204a5206f2d09356c2a2e7b6cbfa0f2e.tar.gz
gnu: gnutls: Enable PKCS#11 support.
PKCS#11 support in GnuTLS is required by Glib-Networking.

* gnu/packages/tls.scm (gnutls)[configure-flags](--without-p11-kit): Expose flag
only if target-system is mips64el.
[propagated-inputs]: Add p11-kit.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tls.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index d52a88fc86..a0d7c5ef22 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -214,7 +214,10 @@ living in the same process.")
 
              ;; FIXME: Temporarily disable p11-kit support since it is not
              ;; working on mips64el.
-             "--without-p11-kit")
+             ,@(if (string-prefix? "mips64el" (or (%current-target-system)
+                                 (%current-system)))
+                 '("--without-p11-kit")
+                 '()))
 
        #:phases (modify-phases %standard-phases
                   (add-after
@@ -250,6 +253,7 @@ living in the same process.")
      ;; These are all in the 'Requires.private' field of gnutls.pc.
      `(("libtasn1" ,libtasn1)
        ("libidn2" ,libidn2)
+       ("p11-kit" ,p11-kit)
        ("nettle" ,nettle)
        ("zlib" ,zlib)))
     (home-page "https://www.gnu.org/software/gnutls/")