summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-07-22 23:24:34 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-07-23 11:33:36 +0200
commit785c96fbe162c55c46b7a14bbfe7ccade8f063f6 (patch)
tree988834809daed4c23979f07ba0c60a176eebe830 /gnu/packages
parent89ea0918a4a6cc9c250b85c0b713e471b7769c48 (diff)
downloadguix-785c96fbe162c55c46b7a14bbfe7ccade8f063f6.tar.gz
gnu: Add radvd.
* gnu/packages/admin.scm (radvd): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/admin.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index f5c5be1901..40acd1fa29 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1288,6 +1288,38 @@ tools: server, client, and relay agent.")
       (license license:mpl2.0)
       (properties '((cpe-name . "dhcp"))))))
 
+(define-public radvd
+  (package
+    (name "radvd")
+    (version "2.19")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/radvd-project/radvd")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1df827m3vkjq2bcs5y9wg2cygvpdwl8ppl446qqhyym584gz54nl"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("bison" ,bison)
+       ("check" ,check)
+       ("flex" ,flex)
+       ("pkg-config" ,pkg-config)))
+    (arguments
+     `(#:configure-flags '("--with-check")))
+    (home-page "https://radvd.litech.org/")
+    (synopsis "IPv6 Router Advertisement Daemon")
+    (description
+     "The Router Advertisement Daemon (radvd) is run on systems acting as IPv6
+routers.  It sends Router Advertisement messages specified by RFC 2461
+periodically and when requested by a node sending a Router Solicitation
+message.  These messages are required for IPv6 stateless autoconfiguration.")
+    (license (license:non-copyleft "file://COPYRIGHT"))))
+
 (define-public libpcap
   (package
     (name "libpcap")