summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2015-11-08 22:05:59 -0500
committerDavid Thompson <dthompson2@worcester.edu>2015-12-05 09:44:37 -0500
commita6b61b271b4abd3ad3c31504d170d5e8f9536cb2 (patch)
tree120eefa9f0a3bb86e047a69f189390d9c2ea5ad1 /gnu/packages
parentd4b77f3662fd903be432a268f5076191cd0da777 (diff)
downloadguix-a6b61b271b4abd3ad3c31504d170d5e8f9536cb2.tar.gz
gnu: Add python-zope-component.
* gnu/packages/python.scm (python-zope-component,
  python2-zope-component): New variables.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 41ac5becd4..d6b43fdae5 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6308,3 +6308,36 @@ security policies on Python objects.")
 
 (define-public python2-zope-security
   (package-with-python2 python-zope-security))
+
+(define-public python-zope-component
+  (package
+    (name "python-zope-component")
+    (version "4.2.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://pypi.python.org/packages/source/z"
+                           "/zope.component/zope.component-" version ".tar.gz"))
+       (sha256
+        (base32
+         "06pqr8m5jv12xjyy5b59hh9anl61cxkzhw9mka33r3nxalmi2b18"))))
+    (build-system python-build-system)
+    (arguments
+     ;; Skip tests due to circular dependency with python-zope-security.
+     '(#:tests? #f))
+    (native-inputs
+     `(("python-zope-testing" ,python-zope-testing)))
+    (propagated-inputs
+     `(("python-zope-event" ,python-zope-event)
+       ("python-zope-interface" ,python-zope-interface)
+       ("python-zope-i18nmessageid" ,python-zope-i18nmessageid)
+       ("python-zope-configuration" ,python-zope-configuration)))
+    (home-page "https://github.com/zopefoundation/zope.component")
+    (synopsis "Zope Component Architecture")
+    (description "Zope.component represents the core of the Zope Component
+Architecture.  Together with the zope.interface package, it provides
+facilities for defining, registering and looking up components.")
+    (license zpl2.1)))
+
+(define-public python2-zope-component
+  (package-with-python2 python-zope-component))