summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2017-09-12 00:29:35 +0200
committerCyril Roelandt <tipecaml@gmail.com>2017-10-10 02:36:34 +0200
commitab28aa229bff7af49ee9a413366000dd61755878 (patch)
treef4a9f9c5f42784b7d89a449a18aade657481c876 /gnu/packages
parent576c0e29cdcf5c344f19bd2e099e3545b4a2c185 (diff)
downloadguix-ab28aa229bff7af49ee9a413366000dd61755878.tar.gz
gnu: Add python-linecache2.
* gnu/packages/python.scm (python-linecache2, python2-linecache2): New
  variables.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index ee37ebb1fe..395e39911c 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -16503,3 +16503,32 @@ their files and supports any packaging format (including wheels).")
 
 (define-public python2-twine
   (package-with-python2 python-twine))
+
+(define-public python-linecache2
+  (package
+    (name "python-linecache2")
+    (version "1.0.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "linecache2" version))
+        (sha256
+          (base32
+            "0z79g3ds5wk2lvnqw0y2jpakjf32h95bd9zmnvp7dnqhf57gy9jb"))))
+    (build-system python-build-system)
+    (arguments
+     `(;; The tests depend on unittest2, and our version is a bit too old.
+       #:tests? #f))
+    (native-inputs
+     `(("python-pbr" ,python-pbr)))
+    (home-page
+      "https://github.com/testing-cabal/linecache2")
+    (synopsis "Backports of the linecache module")
+    (description
+      "The linecache module allows one to get any line from any file, while
+attempting to optimize internally, using a cache, the common case where many
+lines are read from a single file.")
+    (license license:psfl)))
+
+(define-public python2-linecache2
+  (package-with-python2 python-linecache2))