summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2019-12-17 20:36:07 -0500
committerKei Kebreau <kkebreau@posteo.net>2020-04-14 23:53:33 -0400
commite822ab3c7b6072c053b25a175ba802b515edff44 (patch)
tree5b80be49170f8a791824f97e3cd6094c0de65928 /gnu/packages
parent44f210ab90566446c8ccf0a53c663a3d555bad9e (diff)
downloadguix-e822ab3c7b6072c053b25a175ba802b515edff44.tar.gz
gnu: gnome-screenshot: Update to 3.34.0.
* gnu/packages/gnome.scm (gnome-screenshot): Update to 3.34.0.
[arguments]: Add 'skip-gtk-update-icon-cache' phase.
[native-inputs]: Remove gtk+:bin.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gnome.scm14
1 files changed, 11 insertions, 3 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 9fdfa88981..73eaada200 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7580,7 +7580,7 @@ can add your own files to the collection.")
 (define-public gnome-screenshot
   (package
     (name "gnome-screenshot")
-    (version "3.32.0")
+    (version "3.34.0")
     (source
      (origin
        (method url-fetch)
@@ -7589,11 +7589,19 @@ can add your own files to the collection.")
                            name "-" version ".tar.xz"))
        (sha256
         (base32
-         "09ha7dizjm5ymqpjyrqd10ijfb3xlqc1mwg9ajkrbfry11q9yq4b"))))
+         "1rmiq890j7gfn5mcz31xy6jfnnxgc17dq67bhn2k9m5ylbvza2n8"))))
     (build-system meson-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'skip-gtk-update-icon-cache
+           ;; Don't create 'icon-theme.cache'.
+           (lambda _
+             (substitute* "build-aux/postinstall.py"
+               (("gtk-update-icon-cache") "true"))
+             #t)))))
     (native-inputs
      `(("glib:bin" ,glib "bin") ; for glib-compile-schemas, etc.
-       ("gtk+-bin" ,gtk+ "bin") ; for gtk-update-icon-cache
        ("desktop-file-utils" ,desktop-file-utils) ; for update-desktop-database
        ("intltool" ,intltool)
        ("appstream-glib" ,appstream-glib)