summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAndy Wingo <wingo@pobox.com>2015-04-05 20:25:30 +0200
committerMark H Weaver <mhw@netris.org>2015-04-06 17:48:00 -0400
commitd16c9fd80fd094ee03135ba8db281022e1b1ab9a (patch)
treee5b23579d9365e0c5c083a95065e6b40d11518f0 /gnu/packages
parent347f54ed33a0b9a4e234d18dadf950f055e16554 (diff)
downloadguix-d16c9fd80fd094ee03135ba8db281022e1b1ab9a.tar.gz
gnu: Paper over a build circularity problem.
A forthcoming gtk+ update that will import (gnu packages gl) from
(gnu packages gtk) triggers an issue related to circular dependencies
between modules.  This patch works around the issue.

* gnu/packages/sdl.scm: Remove the #:prefix from the (gnu packages fontutils)
  import, and instead #:hide 'freetype' from the (guix licenses) import.

Modified-By: Mark H Weaver <mhw@netris.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/sdl.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/sdl.scm b/gnu/packages/sdl.scm
index 9a3b3898d8..4e9ebfb034 100644
--- a/gnu/packages/sdl.scm
+++ b/gnu/packages/sdl.scm
@@ -20,12 +20,12 @@
 
 (define-module (gnu packages sdl)
   #:use-module (gnu packages)
-  #:use-module (guix licenses)
+  #:use-module ((guix licenses) #:hide (freetype))
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system trivial)
-  #:use-module ((gnu packages fontutils) #:prefix font:)
+  #:use-module (gnu packages fontutils)
   #:use-module (gnu packages guile)
   #:use-module (gnu packages image)
   #:use-module (gnu packages linux)
@@ -260,7 +260,7 @@ SDL.")
                "1dydxd4f5kb1288i5n5568kdk2q7f8mqjr7i7sd33nplxjaxhk3j"))))
     (build-system gnu-build-system)
     (propagated-inputs `(("sdl" ,sdl)))
-    (inputs `(("freetype" ,font:freetype)
+    (inputs `(("freetype" ,freetype)
               ("mesa" ,mesa)))
     (native-inputs `(("pkg-config" ,pkg-config)))
     (synopsis "SDL TrueType font library")