summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-03-24 15:38:17 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-03-24 20:50:44 +0200
commit0e2b817732539c496d3310e42eb4ea5340e8e570 (patch)
treebe717ce1a0f0808e996f29ac39b17dc3f77b0898 /gnu/packages
parent2aab587f842908a886e3bd08b028885dddd650e0 (diff)
downloadguix-0e2b817732539c496d3310e42eb4ea5340e8e570.tar.gz
gnu: glibc: Absorb powerpc patch.
* gnu/packages/base.scm (glibc)[source]: Add patch.
[arguments]: Remove 'apply-patch phase.
[native-inputs]: Remove patch file.
* gnu/packages/commencement.scm (glibc-final-with-bootstrap-bash,
glibc-final)[native-inputs]: Remove patch file.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/base.scm15
-rw-r--r--gnu/packages/commencement.scm10
2 files changed, 3 insertions, 22 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 778f24d465..dbb7c619fe 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -678,7 +678,8 @@ the store.")
             (sha256
              (base32
               "0di848ibffrnwq7g2dvgqrnn4xqhj3h96csn69q4da51ymafl9qn"))
-            (patches (search-patches "glibc-ldd-x86_64.patch"
+            (patches (search-patches "glibc-ldd-powerpc.patch"
+                                     "glibc-ldd-x86_64.patch"
                                      "glibc-dl-cache.patch"
                                      "glibc-hidden-visibility-ldconfig.patch"
                                      "glibc-versioned-locpath.patch"
@@ -874,14 +875,6 @@ the store.")
                                          (map (cut string-append slib "/" <>)
                                               files))))))
 
-                 ,@(if (target-powerpc?)
-                     '((add-after 'unpack 'apply-patch
-                         (lambda* (#:key inputs #:allow-other-keys)
-                           (let ((patch (assoc-ref inputs
-                                                   "powerpc64le-patch")))
-                             (invoke "patch" "--force" "-p1"
-                                     "-i" patch)))))
-                     '())
                  ,@(if (hurd-target?)
                        '((add-after 'install 'augment-libc.so
                            (lambda* (#:key outputs #:allow-other-keys)
@@ -902,10 +895,6 @@ the store.")
                     ("gettext" ,gettext-minimal)
                     ("python" ,python-minimal)
 
-                    ,@(if (target-powerpc?)
-                        `(("powerpc64le-patch" ,@(search-patches
-                                                   "glibc-ldd-powerpc.patch")))
-                        '())
                     ,@(if (hurd-target?)
                           `(("mig" ,mig)
                             ("perl" ,perl))
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index e9d531c07e..f6bfc27843 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -3218,11 +3218,7 @@ memoized as a function of '%current-system'."
      `(("bison" ,bison-boot0)
        ("texinfo" ,texinfo-boot0)
        ("perl" ,perl-boot0)
-       ("python" ,python-boot0)
-       ,@(if (target-powerpc?)
-           `(("powerpc64le-patch" ,@(search-patches
-                                      "glibc-ldd-powerpc.patch")))
-           '())))
+       ("python" ,python-boot0)))
     (inputs
      `( ;; The boot inputs.  That includes the bootstrap libc.  We don't want
        ;; it in $CPATH, hence the 'pre-configure' phase above.
@@ -3366,10 +3362,6 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
 
    ;; This time we need 'msgfmt' to install all the libc.mo files.
    (native-inputs `(,@(package-native-inputs glibc-final-with-bootstrap-bash)
-                     ,@(if (target-powerpc?)
-                         `(("powerpc64le-patch" ,@(search-patches
-                                                    "glibc-ldd-powerpc.patch")))
-                         '())
                     ("gettext" ,gettext-boot0)))
 
    (propagated-inputs