summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-16 02:28:27 -0400
committerMark H Weaver <mhw@netris.org>2018-03-16 05:02:22 -0400
commit3158bc043e32359b6092e5a8c6bc0008ee7e58d3 (patch)
treea55739ee07fffe2682183c22c1de9a89407507f5 /gnu/packages
parentb0559d241b89344d7fef5313bdc1e8ca0869111b (diff)
downloadguix-3158bc043e32359b6092e5a8c6bc0008ee7e58d3.tar.gz
gnu: bzip2: Use invoke instead of system*.
* gnu/packages/compression.scm (bzip2)[arguments]: Use invoke.  In the custom
configure phase, change the 'if' to 'when' and move the #t outside, so that
it's always returned.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/compression.scm28
1 files changed, 14 insertions, 14 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index ea88fb417f..04c33ca868 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -249,23 +249,23 @@ file; as a result, it is often used in conjunction with \"tar\", resulting in
        (modify-phases %standard-phases
          (replace 'configure
            (lambda* (#:key target #:allow-other-keys)
-             (if ,(%current-target-system)
-                 ;; Cross-compilation: use the cross tools.
-                 (substitute* (find-files "." "Makefile")
-                   (("CC=.*$")
-                    (string-append "CC = " target "-gcc\n"))
-                   (("AR=.*$")
-                    (string-append "AR = " target "-ar\n"))
-                   (("RANLIB=.*$")
-                    (string-append "RANLIB = " target "-ranlib\n"))
-                   (("^all:(.*)test" _ prerequisites)
-                    ;; Remove 'all' -> 'test' dependency.
-                    (string-append "all:" prerequisites "\n")))
-                 #t)))
+             (when ,(%current-target-system)
+               ;; Cross-compilation: use the cross tools.
+               (substitute* (find-files "." "Makefile")
+                 (("CC=.*$")
+                  (string-append "CC = " target "-gcc\n"))
+                 (("AR=.*$")
+                  (string-append "AR = " target "-ar\n"))
+                 (("RANLIB=.*$")
+                  (string-append "RANLIB = " target "-ranlib\n"))
+                 (("^all:(.*)test" _ prerequisites)
+                  ;; Remove 'all' -> 'test' dependency.
+                  (string-append "all:" prerequisites "\n"))))
+             #t))
          (add-before 'build 'build-shared-lib
            (lambda* (#:key inputs #:allow-other-keys)
              (patch-makefile-SHELL "Makefile-libbz2_so")
-             (zero? (system* "make" "-f" "Makefile-libbz2_so"))))
+             (invoke "make" "-f" "Makefile-libbz2_so")))
          (add-after 'install 'install-shared-lib
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out    (assoc-ref outputs "out"))