summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2021-11-04 06:08:19 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2021-11-04 06:11:50 +0100
commit63f78f6a6ea0d33f3b1fa68c7285cfb865677211 (patch)
tree31ad5e111a35a01f5c690234827a807fc3056e70 /gnu/packages
parent63c356fe13f0c7cc560a1f9aeec4926422c22137 (diff)
downloadguix-63f78f6a6ea0d33f3b1fa68c7285cfb865677211.tar.gz
gnu: webkitgtk: Use GCC 11 instead of Clang.
WebkitGTK still compiles fine on x86_64 using GCC 11.  This is the only
architecture known to compile currently, as i686 fails with Clang and others
fail due to unsatisfied dependencies.

* gnu/packages/webkit.scm (webkitgtk)[#:phases]: Drop
‘prepare-build-environment’.
[native-inputs]: Drop clang, add gcc.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/webkit.scm9
1 files changed, 2 insertions, 7 deletions
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index e54b680855..7384ead14b 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -295,11 +295,6 @@ acceleration in mind, leveraging common 3D graphics APIs for best performance.")
                  (("libWPEBackend-fdo-([\\.0-9]+)\\.so" all version)
                   (string-append wpebackend-fdo "/lib/" all)))
                #t)))
-         (add-before 'configure 'prepare-build-environment
-           (lambda* (#:key inputs #:allow-other-keys)
-             (setenv "CC" "clang")
-             (setenv "CXX" "clang++")
-             #t))
          (add-after 'install 'move-doc-files
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out"))
@@ -309,8 +304,8 @@ acceleration in mind, leveraging common 3D graphics APIs for best performance.")
                             (string-append doc "/share/gtk-doc"))
                #t))))))
     (native-inputs
-     `(("clang" ,clang-11)
-       ("bison" ,bison)
+     `(("bison" ,bison)
+       ("gcc" ,gcc-11)
        ("gettext" ,gettext-minimal)
        ("glib:bin" ,glib "bin") ; for glib-mkenums, etc.
        ("gobject-introspection" ,gobject-introspection)