summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2016-09-21 03:45:18 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2016-10-30 00:53:50 +0200
commit6cf626e8b3f0c34db7ce7b27cb75da6ad1183120 (patch)
treebd3bcab47a8ab9b1385b6e6ff6895cabe91d61fb /gnu/packages
parent8ed14711dce1baeb0eccab680e259fba845bea89 (diff)
downloadguix-6cf626e8b3f0c34db7ce7b27cb75da6ad1183120.tar.gz
gnu: Add yadifa.
* gnu/packages/dns.scm (yadifa): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/dns.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index e15ebed887..f60f1d1c54 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -5,6 +5,7 @@
 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016 John Darrington <jmd@gnu.org>
 ;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
+;;; Copyright © 2016 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -23,6 +24,7 @@
 
 (define-module (gnu packages dns)
   #:use-module (gnu packages autotools)
+  #:use-module (gnu packages base)
   #:use-module (gnu packages databases)
   #:use-module (gnu packages groff)
   #:use-module (gnu packages linux)
@@ -161,3 +163,40 @@ asynchronous fashion.")
                    license:bsd-3
                    (license:non-copyleft "file://LICENSE") ; includes.h
                    license:openssl))))
+
+(define-public yadifa
+  (package
+    (name "yadifa")
+    (version "2.2.1-6281")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "http://cdn.yadifa.eu/sites/default/files/releases/"
+                           name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0vj71z7i9lfbnp93k28aplwldp5mfli0kvrbwmha6fjha6kcr910"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("which" ,which)))
+    (inputs
+     `(("openssl" ,openssl)))
+    (arguments
+     `(#:phases (modify-phases %standard-phases
+                  (add-before 'configure 'omit-example-configurations
+                              (lambda _ (substitute* "Makefile.in"
+                                          ((" (etc|var)") "")))))
+       #:configure-flags (list "--sysconfdir=/etc"      "--localstatedir=/var"
+                               "--enable-shared"        "--disable-static"
+                               "--enable-messages"      "--enable-ctrl"
+                               ;; NSID is a rarely-used debugging aid, that also
+                               ;; causes the build to fail. Just disable it.
+                               "--disable-nsid")))
+    (home-page "http://www.yadifa.eu/")
+    (synopsis "Authoritative DNS name server")
+    (description "YADIFA is an authorative name server for the Domain Name
+System (DNS).  It aims for both higher performance and a smaller memory
+footprint than other implementations, while remaining fully RFC-compliant.
+YADIFA supports dynamic record updates and the Domain Name System Security
+Extensions (DNSSEC).")
+    (license license:bsd-3)))