summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-09-05 14:46:49 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-09-05 20:03:05 +0200
commite362be8e899707fa85e7ae3102cbb5013d51bb69 (patch)
tree08be68516cf8c5c5b1aff4e43b6836b273294562 /gnu/packages
parent4f8247b54b4bb95fc58b3c4f0c30d635909496e2 (diff)
downloadguix-e362be8e899707fa85e7ae3102cbb5013d51bb69.tar.gz
gnu: Add r-pkgload.
* gnu/packages/cran.scm (r-pkgload): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ae51844dab..9d736d4d6e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -526,6 +526,33 @@ compilers needed to build R packages on various platforms and ensures the PATH
 is configured appropriately so R can use them.")
     (license license:gpl3)))
 
+(define-public r-pkgload
+  (package
+    (name "r-pkgload")
+    (version "1.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "pkgload" version))
+       (sha256
+        (base32
+         "1rjj229nq9fsl4ki4m75ybsavjgpqqhsr1zjzapwicsrxv6212px"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-desc" ,r-desc)
+       ("r-pkgbuild" ,r-pkgbuild)
+       ("r-rlang" ,r-rlang)
+       ("r-rprojroot" ,r-rprojroot)
+       ("r-rstudioapi" ,r-rstudioapi)
+       ("r-withr" ,r-withr)))
+    (home-page "https://github.com/r-lib/pkgload")
+    (synopsis "Simulate package installation and attach")
+    (description
+     "This package simulates the process of installing a package and then
+attaching it.  This is a key part of the @code{devtools} package as it allows
+you to rapidly iterate while developing a package.")
+    (license license:gpl3)))
+
 (define-public r-rcpp
   (package
     (name "r-rcpp")