summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-09 00:10:06 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-15 05:11:31 +0200
commitf541d86de675a33b58488526bdc08b06bd905d8a (patch)
treeb8377a248a9ae582a5eaaf4597b474b552043215 /gnu/packages
parent6aade73967c321b8c8818b63728708e20cd122bc (diff)
downloadguix-f541d86de675a33b58488526bdc08b06bd905d8a.tar.gz
gnu: emacs-tuareg: Don't use unstable tarball.
* gnu/packages/ocaml.scm (emacs-tuareg)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
[arguments]: Add ‘make-git-checkout-writable’ phase.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ocaml.scm21
1 files changed, 13 insertions, 8 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index a565b2e01d..6bb15dc5e9 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -779,20 +779,25 @@ the OCaml core distribution.")
   (package
     (name "emacs-tuareg")
     (version "2.2.0")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "https://github.com/ocaml/tuareg/archive/"
-                                  version ".tar.gz"))
-              (file-name (string-append name "-" version ".tar.gz"))
-              (sha256
-               (base32
-                "1ynpfc170f9jqx49biji9npfkvfpflbm29xf24wc7fnxxayr49ig"))))
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/ocaml/tuareg.git")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "06zxnn85fk5087iq0zxc5l5n9fz8r0367wylmynbfhc9711vccy6"))))
     (build-system gnu-build-system)
     (native-inputs `(("emacs" ,emacs-minimal)
                      ("opam" ,opam)))
     (arguments
      `(#:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'make-git-checkout-writable
+           (lambda _
+             (for-each make-file-writable (find-files "."))
+             #t))
          (delete 'configure)
          (add-before 'install 'fix-install-path
            (lambda* (#:key outputs #:allow-other-keys)