summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-29 20:59:02 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:52:52 -0400
commitf9cd6d905b2f02e5d7a236e7b39454da4d462468 (patch)
treeb1b5a63a0edd40d72030b7ae0f84bcccaba257f0 /gnu/packages
parent87ef43f0152abc554584eb9137637d4467557a1b (diff)
downloadguix-f9cd6d905b2f02e5d7a236e7b39454da4d462468.tar.gz
gnu: non-session-manager: Supersede with new-session-manager.
The new-session-manager project seems a more active fork (and the source of
non-session-manager is no longer available from its project page).

* gnu/packages/music.scm (non-sequencer): Mark as superseded with...
(new-session-manager): ... this new package.
(synthv1, drumkv1, samplv1, padthv1): Replace non-session-manager with
new-session-manager.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/music.scm37
1 files changed, 32 insertions, 5 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index dc34194905..27e2f43743 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -46,6 +46,7 @@
 ;;; Copyright © 2021 Thomas Albers Raviola <thomas@thomaslabs.org>
 ;;; Copyright © 2022 Sughosha <sughosha@disroot.org>
 ;;; Copyright © 2022 Remco van 't Veer <remco@remworks.net>
+;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1750,6 +1751,31 @@ Sequencer happens on-line, in real-time.  Music can be composed live, while the
 transport is rolling.")
       (license license:gpl2+))))
 
+(define-public new-session-manager
+  (package
+    (name "new-session-manager")
+    (version "1.6.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/jackaudio/new-session-manager")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0ihngqbnc50izfy6x7nhgaah00byk8nl6n5smxbyb8fkhm2s8p21"))))
+    (build-system meson-build-system)
+    (native-inputs (list pkg-config))
+    (inputs (list fltk jack-2 liblo libx11))
+    (home-page "https://new-session-manager.jackaudio.org/")
+    (synopsis "Music production session management tool")
+    (description "New Session Manager (NSM) is a tool to assist music
+production by grouping standalone programs into sessions.  It can be used
+create a session, or project, and add programs to it and then use commands to
+save, start/stop, hide/show all programs at once, or individually.  The
+session can be interrupted and easily resumed at a later time.")
+    (license license:gpl3+)))
+
 (define-public non-session-manager
   (package (inherit non-sequencer)
     (name "non-session-manager")
@@ -1768,7 +1794,8 @@ transport is rolling.")
      "The Non Session Manager is an API and an implementation for audio
 session management.  NSM clients use a well-specified OSC protocol to
 communicate with the session management daemon.")
-    (license license:gpl2+)))
+    (license license:gpl2+)
+    (properties `((superseded . ,new-session-manager)))))
 
 (define-public non-mixer
   (package (inherit non-sequencer)
@@ -2255,7 +2282,7 @@ perform creative live mixes with digital music files.")
      (list jack-1
            lv2
            alsa-lib
-           non-session-manager
+           new-session-manager
            liblo
            qtbase-5))
     (native-inputs
@@ -2287,7 +2314,7 @@ oscillators and stereo effects.")
            lv2
            libsndfile
            alsa-lib
-           non-session-manager
+           new-session-manager
            liblo
            qtbase-5))
     (native-inputs
@@ -2319,7 +2346,7 @@ effects.")
            lv2
            libsndfile
            alsa-lib
-           non-session-manager
+           new-session-manager
            liblo
            qtbase-5))
     (native-inputs
@@ -2350,7 +2377,7 @@ effects.")
      (list jack-1
            lv2
            alsa-lib
-           non-session-manager
+           new-session-manager
            liblo
            fftwf
            qtbase-5))