summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2016-09-15 00:38:27 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2016-09-16 01:49:13 +0200
commit71af71dc74906130e3dd7ed2b5bd27e5d4699b52 (patch)
tree8bf239ff13fc1b6aa85994a41ee5aade868794f4 /gnu/packages
parentdd65f3b7444048ca0f537ef01a9b742271b1c536 (diff)
downloadguix-71af71dc74906130e3dd7ed2b5bd27e5d4699b52.tar.gz
gnu: hexchat: Update to 2.12.1.
* gnu/packages/messaging.scm (hexchat): Update to 2.12.1.
[inputs]: Add luajit.
[description]: Wrap to <=80 characters.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/messaging.scm19
1 files changed, 11 insertions, 8 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 3627fecbfa..4e8df544fa 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -166,14 +166,14 @@ identi.ca and status.net).")
 (define-public hexchat
   (package
     (name "hexchat")
-    (version "2.12.0")
+    (version "2.12.1")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://dl.hexchat.net/hexchat/hexchat-"
                                   version ".tar.xz"))
               (sha256
                (base32
-                "17fncwza5r80z9r6j1lrh7h375hp4w6pay08zgnfc3qca6bjy1y2"))))
+                "0svwz9ldrry1sn35jywgpacjj1cf3xl3k74ynwn8rjvxs73b00aj"))))
     (build-system gnu-build-system)
     (native-inputs `(("pkg-config" ,pkg-config)
                      ("intltool" ,intltool)))
@@ -185,14 +185,17 @@ identi.ca and status.net).")
               ("libcanberra" ,libcanberra)
               ("libnotify" ,libnotify)
               ("openssl" ,openssl)
-              ("perl-xml-parser" ,perl-xml-parser) ;for addons
-              ("python-2" ,python-2)))             ;for addons
+
+              ;; Bindings for add-on scripts.
+              ("luajit" ,luajit)
+              ("perl-xml-parser" ,perl-xml-parser)
+              ("python-2" ,python-2)))
     (synopsis "Graphical IRC Client")
     (description
-     "HexChat lets you connect to multiple IRC networks at once.  The main window
-shows the list of currently connected networks and their channels, the current
-conversation and the list of users.  It uses colors to differentiate between
-users and to highlight messages.  It checks spelling using available
+     "HexChat lets you connect to multiple IRC networks at once.  The main
+window shows the list of currently connected networks and their channels, the
+current conversation and the list of users.  It uses colors to differentiate
+between users and to highlight messages.  It checks spelling using available
 dictionaries.  HexChat can be extended with multiple addons.")
     (home-page "http://hexchat.net/")
     (license license:gpl2+)))