summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-09-14 09:37:57 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-09-16 17:29:48 +0200
commitc72c12491ad0ad98fc51a1ede70751531ebf5e87 (patch)
tree92ae54753796380a664ce786398715d6ff44be16 /gnu/packages
parentf6875394a6dce98c78c3d4f222f6f9bc4d5402aa (diff)
downloadguix-c72c12491ad0ad98fc51a1ede70751531ebf5e87.tar.gz
gnu: Add r-rtsne.
* gnu/packages/statistics.scm (r-rtsne): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/statistics.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index f7110ae4d1..68ca2a48f5 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -2529,6 +2529,30 @@ for reproducibility.  Notably, convenient default methods greatly facilitate
 the way current RNG settings can be changed.")
     (license license:gpl3+)))
 
+(define-public r-rtsne
+  (package
+    (name "r-rtsne")
+    (version "0.11")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "Rtsne" version))
+       (sha256
+        (base32
+         "0zi4nxgpiv1gpdmcnqdhz5kymzp8m5xj02zpf290p1yyydl76bhy"))))
+    (properties `((upstream-name . "Rtsne")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-rcpp" ,r-rcpp)))
+    (home-page "https://github.com/jkrijthe/Rtsne")
+    (synopsis "T-distributed stochastic neighbor embedding")
+    (description
+     "This package provides an R wrapper around the fast T-distributed
+Stochastic Neighbor Embedding using a Barnes-Hut implementation.")
+    ;; The declared license for this package is BSD-3, but it also includes
+    ;; code licensed under BSD-4.
+    (license (list license:bsd-3 license:bsd-4))))
+
 (define-public r-nmf
   (package
     (name "r-nmf")