summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-09-07 23:59:51 +0200
committerLudovic Courtès <ludo@gnu.org>2017-09-08 00:11:21 +0200
commitcd1ad27e6cdf90230d07efc18a8fcfe45494aad0 (patch)
tree967b4a872c8b3279a35ed6584028709f1ca94cf4 /gnu/packages
parentcf42428a4a3c182f9d99bebaba868ef47d88c3e2 (diff)
downloadguix-cd1ad27e6cdf90230d07efc18a8fcfe45494aad0.tar.gz
gnu: elogind: Use itself as the cgroup controller.
Fixes a regression introduced in
fa67d5654176b4b815832eaf259188e1486c65ab whereby elogind would fail to
start with:

  Cannot determine cgroup we are running in: No data available
  Out of memory.

thereby preventing log-in altogether.

* gnu/packages/freedesktop.scm (elogind)[arguments]: Pass
"--with-cgroup-controller=elogind".
* gnu/tests/desktop.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/freedesktop.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 3307a4ae80..606859771a 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -227,6 +227,12 @@ the freedesktop.org XDG Base Directory specification.")
        (list (string-append "--with-udevrulesdir="
                             (assoc-ref %outputs "out")
                             "/lib/udev/rules.d")
+
+             ;; Let elogind be its own cgroup controller, rather than relying
+             ;; on systemd or OpenRC.  By default, 'configure' makes an
+             ;; incorrect guess.
+             "--with-cgroup-controller=elogind"
+
              (string-append "--with-rootprefix="
                             (assoc-ref %outputs "out"))
              (string-append "--with-rootlibexecdir="